Stranica: 1/1.

[Problem sa mrežom] Mint ne prepoznaje LAN karticu

PostPostano: 25 lis 2012, 22:22
Postao/la Orangina
Trenutno sam kod frenda, instalirao sam mu Mint13Mate (kao dual boot sa win7). i sad mi Mint ne prepoznaje LAN karticu. Jedino prepoznaje Ralinkovu PCI Wireless karticu preko koje sam i sada spojen. Radi se o Gigabyteovoj maticnoj ploci MA-770-ud3 sa Realtek 8111C/D(L) LANom. Pronasao sam driver (LINUX driver for kernel 3.x and 2.6.x and 2.4.x) tar.gz na Realtekovoj stranici, pokusao pokrenuti autorun.sh, ali mi izbacuje:

Kod: Označi sve
Check old driver and unload it.
Build the module and install


Sto bih sad trebao napravit? Kako se uopce builda modul? Ako nije to onda recite sto je i kako to da rijesim :D Pise da se driver koristi iako lspci nepokazuje niti jedan drugi network controller osim Ralinka.

lspci
Kod: Označi sve
00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD790 PCI to PCI bridge (external gfx0 port A)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD790 PCI to PCI bridge (PCI express gpp port F)
00:12.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB600 Non-Raid-5 SATA
00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI0)
00:13.1 USB controller: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI1)
00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI2)
00:13.3 USB controller: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI3)
00:13.4 USB controller: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI4)
00:13.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB600 USB Controller (EHCI)
00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB600 IDE
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB600 PCI to LPC Bridge
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV730XT [Radeon HD 4670]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]
03:07.0 Network controller: Ralink corp. RT3060 Wireless 802.11n 1T/1R
03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)


Pod win7 LAN radi sasvim normalno.


EDIT: Nakon instaliranja ATI drivera, mint updatea i restarta LAN radi normalno.

Kod: Označi sve
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)


Sto je bio uzrok neznam, volio bih znati, bitno da radi. Ako neko hoce objasniti sto je moguci uzrok, slobodno :)

Re: [Problem sa mrežom] Mint ne prepoznaje LAN karticu

PostPostano: 30 lis 2012, 19:19
Postao/la glaskoncILLa
vjerojatno je modul koji pokusavas buildati vec u kernelu, odnosno uopce ne trebas buildati driver.

pokusaj dodati u /etc/network/interfaces;

auto eth0
iface eth0 inet dhcp

pa

/etc/init.d/networking restart

pa

ifconfig eth0 up

pa onda daj ispis od ifconfig

stavi sudo ispred komande ako i gdje treba.

Re: [Problem sa mrežom] Mint ne prepoznaje LAN karticu

PostPostano: 30 lis 2012, 19:20
Postao/la glaskoncILLa
a rijesio si, nisam procitao do kraja. :)

Re: [Problem sa mrežom] Mint ne prepoznaje LAN karticu

PostPostano: 31 lis 2012, 17:01
Postao/la Netko
Cisto jedna napomena: nikad nemoj instaliravat tako drivere/ista iz source paketa ako neznas sta tocno radis... Koristi pakete i package managere kad vec postoje... U ovom konrektnom slucaju, ko sta je glaskoncILLa reko, driveri su vjerojatno u kernelu... A ako nisu, vjerojatno s razlogom nisu...