Sada je: 28 srp 2021, 15:22.
Linux, poslužitelj, mreže i sigurnost

Moderator/ica: Moderatori/ce

Imam problem sa Huawei E173s 3g stickom, nemogu ga upogoniti na Xubuntuu. Kad ga spojim, dobije prakticki plug n play vodic. New broadband connection, odredim zemlju, ISP (default pise i ispod web.htgprs), potvrdim i kad se treba spojiti pise modem disconnected. Na win7 radi bez pina, ovdje sam probao i ukucavati pin (tj dodavati ga u networkmanageru) ali nista. Krene se spajati ali izbaci. Pise cak T mobile HR UMTS kad kliknem na network applet ali je zasjencano kao da je disableano, a stoji mi dolje "Enabled mobile Broadband". szbunjen
Udarac nogom u guzicu vrijedi 1000 rijeci.
Avatar
Postovi: 262
Postovi: 262
Pridružen/a: 14 ruj 2012, 21:31
Lokacija: Županja / Osijek
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Xubuntu 12.10 / Mint XFCE
Jos nije rijeseno, evo i log dmesg.

Kod: Označi sve
Nakon updatea, ustekan usb u hub (nemam sad free portova :)
[11063.633953] usb 4-2.3: new full-speed USB device number 13 using ohci_hcd
[11064.157278] usb 4-2.3: not running at top speed; connect to a high speed hub
[11064.167256] usb 4-2.3: New USB device found, idVendor=12d1, idProduct=1c0b
[11064.167269] usb 4-2.3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[11064.167277] usb 4-2.3: Product: HUAWEI Mobile
[11064.167284] usb 4-2.3: Manufacturer: HUAWEI
[11064.170626] scsi12 : usb-storage 4-2.3:1.0
[11064.181083] scsi13 : usb-storage 4-2.3:1.1
[11066.430211] usb 4-2.3: usbfs: USBDEVFS_CONTROL failed cmd usb_modeswitch rqt 128 rq 6 len 255 ret -110
[11066.741845] usb 4-2.3: USB disconnect, device number 13
[11066.889634] hub 4-2:1.0: port 4 disabled by hub (EMI?), re-enabling...
[11066.889644] usb 4-2.4: USB disconnect, device number 12
[11067.129293] usb 4-2.4: new full-speed USB device number 14 using ohci_hcd
[11067.257173] usb 4-2.4: New USB device found, idVendor=046d, idProduct=c52f
[11067.257186] usb 4-2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[11067.257194] usb 4-2.4: Product: USB Receiver
[11067.257200] usb 4-2.4: Manufacturer: Logitech
[11067.265684] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.0/usb4/4-2/4-2.4/4-2.4:1.0/input/input18
[11067.266215] hid-generic 0003:046D:C52F.000B: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:12.0-2.4/input0
[11067.273739] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.0/usb4/4-2/4-2.4/4-2.4:1.1/input/input19
[11067.274045] hid-generic 0003:046D:C52F.000C: input,hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:12.0-2.4/input1
orangina@LinuxUSB:~$

Pokusaj spajanja "GSM Network, now you are registered on home network"  - "modem disconnected"

orangina@LinuxUSB:~$ sudo dmesg -c
[11072.006825] usb 4-2.3: new full-speed USB device number 15 using ohci_hcd
[11072.527146] usb 4-2.3: not running at top speed; connect to a high speed hub
[11072.537111] usb 4-2.3: New USB device found, idVendor=12d1, idProduct=1c05
[11072.537124] usb 4-2.3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[11072.537132] usb 4-2.3: Product: HUAWEI Mobile
[11072.537139] usb 4-2.3: Manufacturer: HUAWEI
[11072.542276] option 4-2.3:1.0: GSM modem (1-port) converter detected
[11072.542452] usb 4-2.3: GSM modem (1-port) converter now attached to ttyUSB0
[11072.542647] option 4-2.3:1.1: GSM modem (1-port) converter detected
[11072.542778] usb 4-2.3: GSM modem (1-port) converter now attached to ttyUSB1
[11072.542934] option 4-2.3:1.2: GSM modem (1-port) converter detected
[11072.543066] usb 4-2.3: GSM modem (1-port) converter now attached to ttyUSB2
[11072.553630] scsi14 : usb-storage 4-2.3:1.3
[11072.562591] scsi15 : usb-storage 4-2.3:1.4
[11074.559408] usb 4-2.3: usbfs: USBDEVFS_CONTROL failed cmd usb_modeswitch rqt 128 rq 6 len 255 ret -110
[11075.098738] scsi 14:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[11075.102728] scsi 15:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[11075.115789] sr1: scsi-1 drive
[11075.115967] sr 14:0:0:0: Attached scsi CD-ROM sr1
[11075.116093] sr 14:0:0:0: Attached scsi generic sg3 type 5
[11075.116673] sd 15:0:0:0: Attached scsi generic sg4 type 0
[11075.130403] sd 15:0:0:0: [sdc] Attached SCSI removable disk

Istekao usb

[11465.817819] option1 ttyUSB0: option_instat_callback: error -62
[11465.829797] option1 ttyUSB0: option_instat_callback: error -62
[11465.841773] option1 ttyUSB0: option_instat_callback: error -62
[11465.853775] option1 ttyUSB0: option_instat_callback: error -62
[11465.860780] usb 4-2.3: USB disconnect, device number 15
[11465.861760] option1 ttyUSB0: option_instat_callback: error -108
[11465.861957] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[11465.861973] option 4-2.3:1.0: device disconnected
[11465.866450] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[11465.866481] option 4-2.3:1.1: device disconnected
[11465.869421] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[11465.869441] option 4-2.3:1.2: device disconnected
[11466.002613] hub 4-2:1.0: port 4 disabled by hub (EMI?), re-enabling...
[11466.002624] usb 4-2.4: USB disconnect, device number 14
[11466.246289] usb 4-2.4: new full-speed USB device number 16 using ohci_hcd
[11466.374108] usb 4-2.4: New USB device found, idVendor=046d, idProduct=c52f
[11466.374114] usb 4-2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[11466.374117] usb 4-2.4: Product: USB Receiver
[11466.374120] usb 4-2.4: Manufacturer: Logitech
[11466.385737] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.0/usb4/4-2/4-2.4/4-2.4:1.0/input/input20
[11466.386150] hid-generic 0003:046D:C52F.000D: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:12.0-2.4/input0
[11466.393179] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.0/usb4/4-2/4-2.4/4-2.4:1.1/input/input21
[11466.393328] hid-generic 0003:046D:C52F.000E: input,hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:12.0-2.4/input1

Ustekao usb i dodao pin u networkmanageru te se probao ponovo spojiti (opet modem DC)

[11527.688538] usb 4-2.3: new full-speed USB device number 17 using ohci_hcd
[11528.233802] usb 4-2.3: not running at top speed; connect to a high speed hub
[11528.243853] usb 4-2.3: New USB device found, idVendor=12d1, idProduct=1c0b
[11528.243866] usb 4-2.3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[11528.243874] usb 4-2.3: Product: HUAWEI Mobile
[11528.243880] usb 4-2.3: Manufacturer: HUAWEI
[11528.251425] scsi16 : usb-storage 4-2.3:1.0
[11528.251764] scsi17 : usb-storage 4-2.3:1.1
[11530.500804] usb 4-2.3: usbfs: USBDEVFS_CONTROL failed cmd usb_modeswitch rqt 128 rq 6 len 255 ret -110
[11530.801542] scsi 17:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[11530.801897] scsi 16:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[11530.820499] sr1: scsi-1 drive
[11530.820849] sr 16:0:0:0: Attached scsi CD-ROM sr1
[11530.824158] sr 16:0:0:0: Attached scsi generic sg3 type 5
[11530.824766] sd 17:0:0:0: Attached scsi generic sg4 type 0
[11530.836367] sd 17:0:0:0: [sdc] Attached SCSI removable disk
[11530.898333] usb 4-2.3: USB disconnect, device number 17
[11530.899303] scsi 17:0:0:0: rejecting I/O to offline device
[11530.899312] scsi 17:0:0:0: killing request
[11536.125296] usb 4-2.3: new full-speed USB device number 18 using ohci_hcd
[11536.662563] usb 4-2.3: not running at top speed; connect to a high speed hub
[11536.672584] usb 4-2.3: New USB device found, idVendor=12d1, idProduct=1c05
[11536.672589] usb 4-2.3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[11536.672592] usb 4-2.3: Product: HUAWEI Mobile
[11536.672595] usb 4-2.3: Manufacturer: HUAWEI
[11536.675655] option 4-2.3:1.0: GSM modem (1-port) converter detected
[11536.675742] usb 4-2.3: GSM modem (1-port) converter now attached to ttyUSB0
[11536.675853] option 4-2.3:1.1: GSM modem (1-port) converter detected
[11536.676151] usb 4-2.3: GSM modem (1-port) converter now attached to ttyUSB1
[11536.676250] option 4-2.3:1.2: GSM modem (1-port) converter detected
[11536.678671] usb 4-2.3: GSM modem (1-port) converter now attached to ttyUSB2
[11536.695259] scsi18 : usb-storage 4-2.3:1.3
[11536.706901] scsi19 : usb-storage 4-2.3:1.4
[11538.705852] usb 4-2.3: usbfs: USBDEVFS_CONTROL failed cmd usb_modeswitch rqt 128 rq 6 len 255 ret -110
[11539.236466] scsi 19:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[11539.241374] scsi 18:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[11539.265102] sr1: scsi-1 drive
[11539.266058] sr 18:0:0:0: Attached scsi CD-ROM sr1
[11539.266160] sr 18:0:0:0: Attached scsi generic sg3 type 5
[11539.266438] sd 19:0:0:0: Attached scsi generic sg4 type 0
[11539.279115] sd 19:0:0:0: [sdc] Attached SCSI removable disk
Udarac nogom u guzicu vrijedi 1000 rijeci.
Avatar
Postovi: 262
Postovi: 262
Pridružen/a: 14 ruj 2012, 21:31
Lokacija: Županja / Osijek
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Xubuntu 12.10 / Mint XFCE
Rijeseno, uskoro ide objasnjenje kako :)
Udarac nogom u guzicu vrijedi 1000 rijeci.
Avatar
Postovi: 262
Postovi: 262
Pridružen/a: 14 ruj 2012, 21:31
Lokacija: Županja / Osijek
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Xubuntu 12.10 / Mint XFCE
To te Bog kaznio što si išao koristiti T-mobile!
Drugi put ćeš odabrati neku normalnu mrežu pa će ti sve raditi od prve. Plug and play. :mrgreen:
Avatar
Site Admin
Postovi: 16079
Site Admin
Postovi: 16079
Pridružen/a: 03 tra 2008, 18:09
Lokacija: Svugdi me ima. Slavonija uglavnom.
Podijelio/la zahvalu: 503 puta
Primio/la zahvalu: 531 puta
Spol: M
OS: Mint 17 Cinnamon
Prvo, isprike što u dvije teme pišem o istom, ali u ovom dmesg sam vidio nešto što sam i ja dobivao pa sam morao prokomentirati:

Kod: Označi sve
[11066.430211] usb 4-2.3: usbfs: USBDEVFS_CONTROL failed cmd usb_modeswitch rqt 128 rq 6 len 255 ret -110


I zbog toga mislim da se cijela stvar ne odvija dobro. Nadam se da će ovo objašnjenje u što skorije vrijeme :thumbs
-----------------------------

Izgleda da ipak i je "samo" to:
http://www.linuxhorizon.com/2-debian-linux/0beae3fc5d12d310.htm

Možda rješenje
http://askubuntu.com/questions/179324/huawei-e173-on-ubuntu-12-04
http://ubuntuforums.org/showthread.php?t=1996734&p=12000198#post12000198
Avatar
Postovi: 48
Postovi: 48
Pridružen/a: 10 sij 2013, 23:13
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Debian GNU/Linux; XFCE

Na mreži
Trenutno korisnika/ca: / i 1 gost.