Sada je: 22 stu 2019, 15:46.
Linux, poslužitelj, mreže i sigurnost

Moderator/ica: Moderatori/ce

Pa što ih odmah nisi pitao i za tvoj problem?
Avatar
Postovi: 1897
Postovi: 1897
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 338 puta
Spol: M
OS: Mint 10 LXDE itd...
Evo pričamo i svima nije jasno u čemu je problem... jer po defaultu i debian weezy source i dotdeb source imaju pinning vrijednost 500 i to se nije smjelo dogoditi, ali eto je...
Postovi: 426
Postovi: 426
Pridružen/a: 08 kol 2008, 11:00
Lokacija: Osijek
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 14 puta
Spol: M
OS: Fedora
Da nije netko napravio alias a
na apt-get koji zove sa raznim override funkcijama? postoji i mogućnost Da je neki bug u sustavu ili zlonamjerna modifikacija. u svakom slučaju nije nešto što se dešava normalno ili po defaultu ili je itko doživio.
Es gibt keinen Gott, kein Universum, keine menschliche Rasse, kein irdisches Leben, keinen Himmel, keine Hölle. Es ist alles ein Traum - ein grotesker und dummer Traum. Nichts existiert außer dir. Und du bist nur ein Gedanke - ein vagabundierender Gedanke, ein nutzloser Gedanke, ein heimatloser Gedanke, der verloren in der leeren Ewigkeit wandelt!
Avatar
Moderator
Postovi: 9917
Moderator
Postovi: 9917
Pridružen/a: 07 pro 2007, 18:07
Podijelio/la zahvalu: 158 puta
Primio/la zahvalu: 270 puta
Spol: Y
OS: utuntu 17.04
Ili u nekoj skripti ima forceanu staru verziju, ili nešto kao apt-get install -t stable ili ...install /stable sl. Ili, pošto su pinovi jednaki ovaj preferira target release. Ali svejedno ne bi smjelo jer je verzija veća. Možda je negdje zadržana ta novija verzija (u aptu ili dpkg bazi). Ko zna, najbolje da povećaš pin na onome dotdebu ali to nije rješenje ako ne možeš napraviti test da budeš siguran da u budućnosti neće biti sr@nja.
Avatar
Postovi: 1897
Postovi: 1897
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 338 puta
Spol: M
OS: Mint 10 LXDE itd...
valent je napisao/la:
shrike je napisao/la: inače je aptitude debian preporučeni alat, a ne apt-get

Ova izjava nije točna, sada sam pitao na #debian i njihov odgovor je kako je jedini službeni paket manager dpgk a oba frontenda imaju podjednaku preporuku, i svaki ima svoje prednosti i mane:


https://wiki.debian.org/DebianPackageManagement

Generally, the command line tools integrate a number of operations (package list management, package retrieval, package installation, package configuration) in a single command plus arguments. The primary command line tool is aptitude. apt-get fulfills a similar purpose and although it is no longer the recommended primary tool some still use it.
Es gibt keinen Gott, kein Universum, keine menschliche Rasse, kein irdisches Leben, keinen Himmel, keine Hölle. Es ist alles ein Traum - ein grotesker und dummer Traum. Nichts existiert außer dir. Und du bist nur ein Gedanke - ein vagabundierender Gedanke, ein nutzloser Gedanke, ein heimatloser Gedanke, der verloren in der leeren Ewigkeit wandelt!
Avatar
Moderator
Postovi: 9917
Moderator
Postovi: 9917
Pridružen/a: 07 pro 2007, 18:07
Podijelio/la zahvalu: 158 puta
Primio/la zahvalu: 270 puta
Spol: Y
OS: utuntu 17.04
Apt nije blesav niti ce ikad downgradeati paket ako mu nije tako receno.
A receno mu moze biti u imenu filea, odnosno ta ekipa koja je skrpala file u tom nesluzbenom repozitoriju vjerojatno nije razmisljala o utjecaju imena paketa na upgrade zbog cega se desio kurzslus.

Pisem s mobitela pa mi se ne da objasnjavati detalje, ali objasnjenje lezi u dokumentaciji.
...."Have you mooed today?"...
..It’s that time of the decade: I’m reinstalling Debian..
Avatar
Postovi: 5677
Postovi: 5677
Pridružen/a: 28 vel 2009, 16:36
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 41 puta
heh, moram priznati kada sam zeznuo... nakon što su se stvari malo slegle pregledao sam još jednom sve, i izgleda da apt-get i Debian nisu zeznuli stvari već dotdeb paketi!

Dvije su se stvari mogle dogoditi:
1. netko od developera ručno dodao "explicit_defaults_for_timestamp" u /etc/mysql/my.cnf i ne želi priznati
2. dotdeb verzija mysql paketa je prepravila samo my.cnf bez da instalira mysql 5.6 verziju do kraja...

Dakle Debian Rulez!!! :)
Postovi: 426
Postovi: 426
Pridružen/a: 08 kol 2008, 11:00
Lokacija: Osijek
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 14 puta
Spol: M
OS: Fedora
drago mi je da se riješilo sve. i opet nas uči da teba paziti koje se repo dodaje (zato su mi uvijek bili sumnjivi ppa)
Es gibt keinen Gott, kein Universum, keine menschliche Rasse, kein irdisches Leben, keinen Himmel, keine Hölle. Es ist alles ein Traum - ein grotesker und dummer Traum. Nichts existiert außer dir. Und du bist nur ein Gedanke - ein vagabundierender Gedanke, ein nutzloser Gedanke, ein heimatloser Gedanke, der verloren in der leeren Ewigkeit wandelt!
Avatar
Moderator
Postovi: 9917
Moderator
Postovi: 9917
Pridružen/a: 07 pro 2007, 18:07
Podijelio/la zahvalu: 158 puta
Primio/la zahvalu: 270 puta
Spol: Y
OS: utuntu 17.04

Na mreži
Trenutno korisnika/ca: / i 3 gostiju.